NHD-7.0CTP-CAPE - BBB does not start up properly



  • Paul_B

    I’m sorry to hear about the trouble you are having with the NHD-7.0CTP-CAPE.

    It would be helpful to see your boot process. To see the actual boot process a RS232 cable like the TTL-232R-3V3 from FTDI is needed. Just plug it into the J1 connector (located on the BBB) and open a serial terminal of your choice.

    Lastly, can you confirm that everything is operational with your beagleboneblack wireless? You wouldn't happen to have a second one available for testing?

  • Paul_B
    I know this might sound odd but can you please tell me what brand microSD card you are utilizing?

    It sounds like an obvious thing to avoid, but sadly, is there any chance you purchased a fake/bad microSD card?

  • hendrik
    There is no output during boot process when the cape is attached, since it just shuts down immediately. I tested it with 2 bbbwl on 2 capes. SD cards are xlyne microSD HC class 10 and a sandisk ultra hc class 10, both 16gb, but usually not in use, because I boot from mmc. To me it looks like some start-up overcurrent issue with a shutdown caused by OSD3358 power management chip.
    I tried disconnecting the SYS_5V on startup and attached it after boot process. With this configuration the bbb boots properly and the display can be used, but this is obviously way too uncomfortable.

    Additionally I tried it with a BBB (non wireless) and everything works fine out of the box.
  • Paul_B
    Thank you for the information, can you please let me know which NHD-7.0CTP-CAPE you purchased i.e. L, N, or V?

    Are you using the Images available for download in the User Guide or spinning your own overlay?

    The NHD-7.0CTP-CAPE was originally designed for the BeagleBone Black (non wireless) back in 2016. I'll try to get my hands on the BBB (wireless) early next week and see if I can replicate the issue you are experiencing.
  • Paul_B

    Afternoon Hendrik,

    I've completed testing on the NHD-7.0CTP-CAPE utilizing the new BeagleBone Black Wireless and managed to replicate the issue you are experiencing. The issue seems to stem from the OSD3358 power management chip exclusively on the new BeagleBone Black Wireless model.

    If you are having this issue, please see the work-around below:

    Disclaimer:Modified product will void warranty.

    • Cut pins 7 & 8 on connector P1_B
    • Solder a 0 Ohm resistor (or solder bridge) between pins 5 & 7

    This enables the backlight circuit to run off VDD_5V (main power supply from the DC input jack) instead of SYS_5V (main rail for the regulators on the main board).

  • newto
    Hello Hendrik and/or Paul_B

    Lucky timing that this question popped up recently, as I have a related one.

    Do the wireless functions (wifi and bluetooth) still work with the 24-bit cape installed (and the modifications listed complete)? I've seen a few places that some of the extra pins required for 24 bit over 16 bit colour are also used for wireless addons for earlier beaglebone boards, and I wanted to make sure those features still work with the integrated wireless chip.
  • Paul_B
    Hi Newto,

    I believe the WiFi/Bluetooth pins were taken from the 10/100 Ethernet pins (don't quote me on that)...

    The BeagleBone Black Wireless is still fairly new to me, I'll have to do some additional testing to confirm 
  • jerryp
    I too am having no luck getting the NHD-7.0CTP-CAPE -L to work with my Beaglebone Black Wireless. I tried the modified power configuration that you described in an earlier thread - removing pins 7 and 8 (P1_B) from the circuit then shorting 7 to 5. No success. I get a boot and a heartbeat. But, no cape display function.
    This particular BBB-WL works with other capes including HDMI type. So, I can confirm that it is functional I also have 5 more BBB-WL and 5 more NHD-7.0CTP-CAPE-L units to work with. Same unsuccessful results.

    I have another project where I use this exact cape with a regular BBB and it seems to be fine.
    Is this just a compatibility issue that cannot be resolved, or is there hope?

  • Paul_B
    Hi Jerry,

    I’m sorry to hear about the trouble you are having with the NHD-7.0CTP-CAPE, it appears to be a software issue.

    The following thread should provide a solution:

    Unfortunately, I don't have the BBBW (wireless) in the lab at this time... I'll try and get my hands on another one early next week so I can confirm 
  • jerryp
    Thank you. I would appreciate that. In the mean time, I will check out the recommended link.

    Cheers -
  • Paul_B

    Morning Jerry,

    My BBBW (wireless) has arrived and I've started testing.

    Out of box the default Debian Jessie OS (booting off the eMMC) appears to run with no problems.
    Note: No modifications were made to the NHD-7.0CTP-CAPE

    The NHD cape should be supported out of the box (unless an old version of u-boot get's the way).

    For trouble shooting purposes can you please answer the following:

    What OS are you running?
    What is your 5V power supply rated to?

    In the mean time I'll begin testing the images listed in our User Guide via a microSD card.


  • jerryp

    Here is the OS info..

    debian@beaglebone:~$ hostnamectl
       Static hostname: beaglebone
             Icon name: computer
            Machine ID: 4bd52b1b216d4c40a02bb44c887ac3bb
               Boot ID: 900a1815cb6046fe996fed71658994ef
      Operating System: Debian GNU/Linux 8 (jessie)
                Kernel: Linux 4.4.41-ti-r83
          Architecture: arm

    My power supply is 5v 2A

  • MattB0ne
    I am also having problems with NHD-7.0CTP-CAPE-V. Has anyone performed any testing to ensure it is still compatible if you are using a recent image?

Please sign in to leave a comment.