NHD-7.0-800480EF-ATXV reset



  • Michael_L

    Having no control over the AVDD line is not an issue, this is handled by the controller board.  Since you said you had the display working fine, the problem seems to be something to do with your MCU or how it is powering up.  I would tell you to ensure you are handling the reset line correctly at power on, but since you have it working with your processors debugger, it seems like you are already meeting this requirement.  Is there any way to make sure the reset line is low at the very beginning of your code and then bring it high, wait 250ms, pull it low, wait 250ms, and bring it high again and wait another 250ms?
    Is the power supply different between the two ways you tried running the display?

  • lensfocus

    Thanks for your reply.
    The power supply is the same in both cases.

    This has to be something wrong on our PCB I am guessing, I mainly wanted to see if this had happened to anyone else.

    I tried your test of holding the reset line low at bootup for 250ms, then high for 250, then low for 250, then high (for 250ms) again, it still does not show images.

    An interesting point is that when I leave the reset line floating using the debugger the screen works, but even when still using the debugger and following the above test toggling the reset line, the screen initializes strangely; the background color that I am painting on the screen is shifted left 1/5th of the screen with no images on the screen after that.

    So again, I am assuming there is something wrong with our reset or ground connections or something like that, I will repost here when I find the solution.

  • lensfocus

    Okay, got it working.

    Still a bit confusing as to why.. Here is what I ended up doing:

    Immediately on bootup I toggle the reset line (2ms low, 2ms high), and then run through the software TFT initialization procedure.

    Then I go through the rest of the processor bootup procedure, which includes a 250mS delay for analog initialization.

    Then I re-run the TFT initialization procedure and the screen works properly.

    If I don't run the software initialization procedure twice, the screen doesn't run... again I'm not sure why, but at least this works.



Please sign in to leave a comment.